build L2TP VPN

L2TP (Layer 2 Tunneling Protocol) VPN is a tunneling technology used to carry PPP messages, which is mainly used in remote office scenarios to provide access to corporate intranet resources for traveling employees.

L2TP (Layer Two Tunneling Protocol) is a type of virtual private dial-up network (VPDN) technology that allows dial-up users to initiate a VPN connection from an L2TP client or L2TP access concentrator (LAC) to connect to an L2TP network server (LNS) via point-to-point protocol (PPP). LNS). After a successful connection, the LNS assigns IP addresses to legitimate users and allows them to access the private network.

The device acts as the LNS in the L2TP protocol tunneling network. It accepts connections from L2TP clients or LACs, performs user authentication and authorization, and assigns IP addresses, DNS server addresses, and WINS server addresses to legitimate users.

The L2TP protocol does not encrypt data during tunnel transmission, so it cannot ensure data security. Users can use L2TP protThe L2TP protocol can be used in conjunction with the IPSec protocol to take advantage of the encryption of data offered by IPSec to ensure data security in L2TP tunnel transmission.trial router: VPN —–L2TP setup interface, corresponding to Cisco L2TP configuration content as shown in the following figure.
(see the last page for detailed configuration of Cisco commands)

Alotcer 5G/4G industrial router “operational status” interface to view the L2TP connection status

Alotcer 5G/4G industrial router

In the Cisco interface with the source ping Ailutong router 192.168.1.1 subnet

 Cisco interface with the source

Ping Cisco’s 200.200.200.1 subnet with source in Airutong 5G/4G industrial router

Ping Cisco's 200.200.200.1 subnet with source

Industrial Cellular Router

Cisco L2TP configuration.
vpdn enable
!
vpdn-group 1
! Default L2TP VPDN group
accept-dialin
protocol l2tp
virtual-template 1
no l2tp tunnel authentication
!
memory-size iomem 0
username xmalt password 0 xmalt001
!
interface Loopback0
ip address 10.10.10.10 255.255.255.0
!
interface Loopback1
ip address 200.200.200.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.27.80 255.255.255.0
duplex half
!
interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address pool l2tp-pool
ppp authentication ms-chap pap ms-chap-v2

iIP local pool L2TP 10.10.10.10 10.10.10.50
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.27.1

Related Posts

View all
  • Continue reading
  • Continue reading
  • Cat 1 is an LTE communication standard designed for the express aim of servicing IoT […]

    Continue reading
  • As we all know, 5G industrial routers are mostly used in the industrial field, especially […]

    Continue reading

Products related